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1. Revision History
Version

Date

Description

v1.0

September 2019

Initial Release

This User Guide is intended as a manual for the PG-Find™ Software v2.0.

2. Self-Reference Algorithm Basics
The self-reference algorithm works by dividing the genome of an individual sample into user-specified
size windows (bins) and calculating the number of reads in each bin. Regions containing reads aligning to
anomalous, unstructured and highly repetitive sequence are filtered and removed from the analysis. The
software calculates the median read count across all bins and uses this value to normalise and assign each bin
a copy number value. A systematic correction is applied to correct for any effects of GC content or bias.
After normalisation a statistical algorithm is used to separate (segment) the genome into clusters containing
bins with similar copy number values. The algorithm is controlled by a parameter called the Significance
Threshold which determines whether clusters are significantly different from neighbouring clusters to
be segmented. If the distribution of bins in a cluster is significantly different to a neighbouring cluster
(generating a significance value less than the significance threshold), the clusters are segmented. At the
completion of the segmentation process, the entire genome is represented as a series of segments with each
segment assigned a copy number value. If the segment copy number value is outside of the user-defined
thresholds, a copy number gain or loss will be called.

3. Requirements for Using the PG-Find™ Software
Access to the PG-Find™ software is included as part of each kit in the range of PG-Seq™ Kits.
The PG-Find™ software requires installation onto a single stand-alone computer with the following hardware
specifications at a minimum
• Operating system:
• Memory:
• Hard-drive:
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Windows 64-bit, Mac OS X
Minimum 4GB (recommended 8GB)
Minimum 500GB
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4. Download, Installation & Activation

2.
3.
4.
5.

Download the PG-Seq™ software setup application by visiting the following link
installers.biodiscovery.com/PG-Find/Release%201.1/Windows64/VM/PG-Find.exe.
Double-click on the setup application icon to start the installation process.
Click “run” when prompted, then follow the installation prompts.
Once installed, launch the software.
Click “Request activation key via email”.

6.

Complete the “Activation request data” form.

7.

Click “Launch Mail Client”. This should open your email client with a pre-filled request (if an email client
is not launched, then click “Copy to Clipboard” and paste the pre-filled request in an email). Send the
request email to NGS@perkinelmer.com.

8.

Once you have received your licence code (please allow 1-2 business days), click “Activate now”.

1.
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9.

Copy and paste your licence code into the “Enter activation code” field then click “OK”.

NOTE: Please contact PerkinElmer at NGS@perkinelmer.com if you are experiencing issues with
installation or activation of the PG-Find™ software.

6
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5. Launching the Software and Creating a Project
1.

Launch the PG-Find™ Software.

2.

On the Home screen, click “New Project”.

3.

Enter a unique project name in the “Project Name” field then click “Create”.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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6. Default Settings
The settings inform the analysis and define the minimum attainable resolution, dependent on data quality.
The default settings are recommended and are optimised for detecting copy number events of 5Mb or larger.
The default settings are presented below:

If the settings displayed do not match the above values, the settings can be returned to default by clicking
“Default”.
NOTE: After changing settings, any samples already loaded in the project will need to be reanalysed with the
new settings. See Reanalysing Data section for instructions.
NOTE: When loading new samples into an established project, they will be automatically processed with the
currently active settings. Settings do not load with projects, so be conscious of this when switching between
projects that may use different settings.

8
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7. Loading Data
After a project has been created or loaded, sample data can be added to the project.
To add samples to a project:
1.

On the “Data Set” tab click “Load” then “Load Data”.

2.

Navigate to the location of your BAM files.

3.

Select the BAM files you wish to analyse then click “Open”.

4.

Click “Done” to begin processing the selected files.

NOTE: Sample processing may take up to several minutes, depending on the bin size setting and number of
mapped reads. Processing will take longer with smaller bin sizes (i.e. more bins) and more mapped reads.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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8. Analyzing Data
1. Once processing is complete, an overview of the sample results will appear in the “Results” tab.

This tab shows the results of each individual sample in an overview page. Sample names appear in rows on
the left side of the page, each with a hyperlink to see further information. Each chromosome is listed in
columns. A red line indicates a copy number loss while a blue line indicates a copy number gain.
2. Select the “Data Set” tab.

The “Data Set” tab shows additional information about each sample including the quality and sample
metrics from sequencing and alignment. For information on each metric, please see Table 1. The data can be
exported by selecting “Tools” > “Export TXT”.

10
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Additional columns with user editable fields can be added by selecting “Factors” > “Add Factor.

Factors can be shown or hidden from view by selecting the “Modify View” button.

Table 1: Quality and Sample Metrics
Metric
Sample

File name of the BAM file that was loaded.

Status

The processing status of the sample. The “processed” link can be selected to see what
settings each sample was processed with.

Quality

The bin to bin variance in each sample before data smoothing, analogous to standard
deviation. A lower quality score indicates more reliable data while a higher quality
score indicates less reliable data. The quality score will vary based on the bin width
selected and the number of usable reads per sample and per bin. An acceptable quality
score should be determined and validated in each laboratory. A high quality score can
indicate low quality DNA or issues during the WGA or library preparation.

Total CN
aberrations

The total number of copy gains or copy losses detected by the software for each sample.
A copy gain will be called if the copy number ratio of a chromosome or chromosome
segment is greater than the user specified “Gain” value in the settings. Similarly, a copy
loss will be called if the copy number ratio of a chromosome or chromosome segment
is less than the user specified “Loss” value in the settings.

Total reads

The total number of reads assigned to a particular sample after de-multiplexing.

% mapped
reads

The percentage of reads which successfully align to hg19. Lower values can indicate
non-human contamination in your final library DNA.

Usable
reads
Mt DNA
load %

The number of reads available for copy number analysis after PG-Find™ Software
filtering. Reads aligning to anomalous, unstructured and highly repetitive sequence are
filtered from the analysis.
The percentage of mitochondrial DNA reads as a percentage of the number of
autosomal mapped reads.

Saving Images
All images seen in the “Results” tab and “Sample Drill Down Window” can be saved as a .png file by clicking
the save button.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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3.

Return to the “Results” tab then select each sample hyperlink to obtain additional information about
individual samples.
a.

Sample Info:

The Sample Info tab displays the same information seen in the “Data Set” tab. Additional sample notes
can be added by selecting the “Edit” button at the bottom of the page.

12
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b.

Overview:

The “Overview” tab displays an ideogram with copy number gains highlighted in blue and copy number
losses highlighted in red.

c.

Whole Genome:

The “Whole Genome” tab displays a smoothed graphical representation of the chromosome profile.
Chromosome numbers are listed on the x-axis and a copy number ratio is listed on the y-axis. Each grey
data point or bin represents a region on the genome. The copy number value of each bin is calculated by
comparing the number of reads in that region against the median of the whole sample.
The pink segment line represents the median copy number value for a cluster of bins and the black line is
the moving average. The red and blue lines indicate the threshold values and determine the calling of copy
number events. When the segment line is above the lower blue threshold line it is called as one additional
copy of that region, when it is above the upper blue line it is called as two additional copies. Similarly, when
the segment is below the upper red line it represents one copy loss, whereas when it is below the lower red
line it is two copy losses. The locations of the threshold lines can be adjusted in the settings menu, although
this is not recommended.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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d.

Chromosome Tab:

The Chromosome tab allows you to view each chromosome in more detail and displays the raw unsmoothed
data. Different chromosomes can be selected by using the dropdown menu in the top left of the screen. As
well as providing a zoomed image of each chromosome, all copy number events across all chromosomes
for the sample are listed in the table at the bottom. Each event has additional details such as the length and
cytoband position.

A summary of the events, including settings used, can be exported using the “Export TXT” button.
The region displayed in the “Chromosome Region” field is a hyperlink that will show a list of common genes
and CNVs published from that region if clicked.
The event type displayed in the “Event” field is a hyperlink that will zoom to the event if clicked.
The “Length” field displays the length of the copy number event region in bases.

14
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The “Cytoband” field displays the cytobands involved in the copy number event.
The “Probe Median” field displays the median copy number of the probes in the copy number event.
The number of probes in the copy number event region are displayed under the “Probes” field, which is also
a hyperlink that if clicked will show a table containing the start and end point of each probe in the event, the
CN ratio, and the segment line value.
Summary Tab:
The “Summary” tab displays an ideogram similar to the “Overview” tab with copy number gains highlighted
in blue and copy number losses in red. This tab also includes a simplified graphical representation of the
genome profile.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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9. Manual Addition of Copy Number Calls
Regions of each chromosome can be manually called as a copy gain or loss using the “Add/Join Region”
function in the Chromosome tab.
To manually call a copy number gain or loss:
1.

Zoom into the location of the region or enter the region coordinates into the Search field.

2.

Select the Add/Join Region icon.

3.

Confirm the Chromosome Region is correct.
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4.

In the Event dropdown, select the relevant copy number event.

5.

Click “Ok”.

The selected region has now been assigned as a Copy Number Loss, with details present in the results table.
To remove the manual call, highlight the event in the table then select Delete Regions.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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10. Gender Estimation
The PG-Find™ software has an inbuilt gender estimation algorithm with automatic threshold adjustment.
When the software detects a Y-chromosome copy number ratio above a set threshold, the sample is
designated as male and the expected copy number thresholds for both the X and Y chromosome are adjusted
to allow for automatic copy number calling.
See below for examples of possible sex chromosome results and the associated gender estimation and copy
number calling.

1
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5
7
6
7
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Sample 5

Sample 6

Sample 7

XXY

XX

XYY

In this sample chromosome Y has
been detected. The copy gain and
loss threshold lines are adjusted and
the sample is estimated to be Male.
Because the bins of chromosome X
are above the copy gain threshold
line (blue line), a gain of
chromosome X has been called. The
X chromosome has a copy number
value of 2 and the Y chromosome
has a copy number value of 1,
indicating this sample is XXY.

In this sample no chromosome Y is
detected. There is no change to the
sex chromosome threshold lines and
the sample is estimated to be
Female. The copy number value of
the X chromosome is 2, and the Y
chromosome is 0, indicating this
sample is XX.

In this sample chromosome Y has
been detected. The copy gain and
loss threshold lines are adjusted and
the sample is estimated to be Male.
Because the bins of the Y
chromosome are above the copy
gain threshold (blue line), a gain of
chromosome Y has been called. The
X chromosome has a copy number
value of 1 and the Y chromosome
has a copy number value of 2,
indicating this sample is XYY.

If the gender estimation is incorrect, which is especially possible in cases where the gender is not clearly XX
or XY, the user can manually correct the value in the Gender field then reprocess the sample. Acceptable
values for the Gender field include M, F, Male, Female, male, female, unknown. If the Gender value is deleted
and left as blank, the sample will be reset, and the gender will be re-estimated during processing.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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11. Exporting Probe Values
Probe values for each sample (in logR) can be exported to a text file.
To export probe values:
1.

Mark off the checkboxes for the samples of interest on the Data Set tab.

2.

go to “File” > “Utilities” > “Convert .ivg to .txt”.

3.

Select a folder to store the output (one folder will be created per sample) and click “Open”.

4.

After export, within each sample folder will be a probes.txt file with the bins and logR values. To
convert logR values to copy number values, use the formula: 2*(2^logR value).

20
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12. Display Options
The display options control the aesthetics of the Whole Genome and Chromosome copy number variation
(CNV) plots. The default settings are recommended. To change the Display Options:
1.

Click “File” > “Options”.

2.

Under the “Display Options” tab, change the options as desired then click “Save”.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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13. Adjusting the Settings
The PG-Find™ software is unique in that users can change settings to accommodate the available data,
allowing customisable analysis for data input and resolution. In the settings menu, the options “Target bin
width” and “Significance Threshold” can be adjusted to achieve higher or lower resolution.
To adjust the settings:
1.

22

Click “File” > “Settings”.
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2.

Adjust the settings as desired. “Target bin width” and “significance threshold” are the most important
variables influencing resolution (see below for explanation of these settings).

a.

Target bin width

This is the target size of bins or sections of the chromosome along the genome in base pairs. It is
recommended that the bin size is based on the desired minimum resolution but limited by the number
of reads per bin. As a guide, it is recommended to use a bin width that is 10% of your desired minimum
resolution. E.g. for 5Mb minimum resolution, use a target bin width of 500,000. Table 2 displays a guide for
setting target bin width according to desired CNV size resolution and number of mapped reads available.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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NOTE: The default settings are optimised for detecting copy number events of 5Mb or larger, so adjustment
of target bin width should not be necessary unless desired minimum resolution is below 5Mb, or the
requisite mapped reads are not available.
NOTE: The attainable resolution is dependent on the quality of the data, including number of mapped
reads. Based on a standard 48 sample run using the PG-Seq™ Kit 2.0 or PG-Seq™ Rapid Kit for Illumina
seqeuncing, resolution below 5Mb is not guaranteed. Based on a standard 96 sample run using PG-Seq™
Rapid Kit for Ion Torrent sequencing, resolution below whole chromosome aneuploidy is not guaranteed.
NOTE: Significance threshold values should be adjusted when adjusting bin width. For smaller bins it
is recommended to use more stringent (smaller) values, and for larger bins it is recommended to use less
stringent (larger) values.
Table 2: Resolution Guide for PG-Seq™ 2.0 Kit and PG-Seq™ Rapid Kit for Illumina Sequencing
Target Resolution

Number of Mapped Reads

Target Bin Width

Whole chromosome

150,000

500,000-2,000,000

10Mb

250,000

500,000-1,000,000

5Mb

500,000

500,000

2Mb

1,000,000

200,000

1Mb

3,000,000

100,000

0.5Mb

12,000,000

50,000

0.1Mb

24,000,000

10,000

This is a guide; the attainable resolution is dependent on individual sample data quality. These data were
generated from in silico testing using PG-Seq™ 2.0 Kit and PG-Seq™ Rapid Kit for Illumina data and should
be validated for use in a clinical setting.
b.

Significance Threshold

The significance threshold sets the amount of difference required for any two clusters of bins to be deemed
significantly different to one another and to be subsequently separated into individual segment lines. Using a
less stringent (larger) value for this threshold reduces the difference required for two clusters to be separated.
A more stringent (smaller) value increases the difference required for two clusters to be separated. A less
stringent value is more likely to cause false positive results whereas a more stringent value is more likely to
cause false negative results. In other words, less stringent sig. thresholds can be set to improve detection
of copy number events, but caution will be needed when interpreting the results as the likelihood of false
positives will increase.
NOTE: Some copy number events in the range of 5-10 Mb may not be detected using the default settings.
To investigate these events, provided the requisite mapped reads are available, we recommend reanalysing
the data using a sig. threshold of 1.0E-6 (no adjustment to other settings), but caution will be needed when
interpreting the results as the likelihood of false positives will increase.
3.
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Click “Done”.
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14. Importing and Exporting Settings
If settings other than the default settings are going to be consistently used, custom settings can be saved. To
export custom settings:
1.

With the settings window open, after adjusting settings click “Save”.

2.

Enter a file name and select a location on your local storage then click “Save”.

To import a saved settings file:
1.

With the settings window open click “Load”.

2.

Select the settings XML file from your local storage, then click “Open”.

3.

Click “Done”.

NOTE: After changing settings, any samples loaded in the project will need to be analysed with the new
settings. See Reanalysing Data section for instructions.

15. Reanalysing Data
The same sample can be analysed using different settings to gain further insight into the data. To reanalyse an
existing sample with new settings:
1.

Ensure the desired settings are set.

NOTE: See Adjusting Settings section for advice on what settings to use and how to enter new settings.
2.

On the “Data Set” tab, highlight the samples for reanalysis.

3.

Click “Duplicate”. A duplicate of each highlighted sample will be generated at the bottom of the list
with “copy” amended to the end of the sample name.

4.

Select the duplicated samples by marking the checkbox of the samples or highlighting the samples and
click “Select”.

5.

Click “View”. The samples will be processed and the “Results” tab (or “Sample Drill Down Window”
for a single sample) will be opened.

perkinelmer-appliedgenomics.com/pg-seq | Support: NGS@perkinelmer.com
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16. Recommendations and Cautions
•

We recommend complementing calls made by the software with visual inspection of the copy number
events. In some cases, visual inspection of the probes can provide improved resolution of the segment
(e.g. around breakpoints) called by the software.

•

The acrocentric chromosomes (chromosomes 13-15 and 21-22) are likely to have no probes on the
p-arms. For these chromosomes, caution needs to be taken when interpreting copy number events
involving the p-arm; if a copy number event is called at the start of the q-arm, the event will be called
through the p-arm also, as no probes exist on the p-arm to inform the algorithm to the contrary. In
theory, such a copy number event may signal a segment on the q-arm only, or a segment on the q-arm
that bridges the centromere and involves any part of the p-arm from the q-arm end.

•

When loading new samples into an established project, they will be automatically processed with the
currently active settings. Settings do not load with projects, so be conscious of this when switching
between projects that may use different settings.

•

There are two methods for selecting samples; by marking the checkbox next to a sample name and by
highlighting a sample row by clicking the sample name. The checkbox selection is only used for the
“View” button. For other buttons such as “Delete” and “Reset”, the samples need to be highlighted.
Multiple samples can be highlighted by click and dragging the mouse, and multiple sections can be
used by holding down the “Ctrl” key. Highlighted samples can have the checkbox marked by clicking
the “Select” button.

17. Software Demo
For a software demonstration or technical support, please contact NGS@perkinelmer.com
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NOTES
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